30.1.08

Axis2 Web Services Container on OC4J

I was working on a project to call Oracle Data Integrator (ODI) from Oracle ESB as part of integration scenario. Part of the ODI installation is to set up infrastructure for public web services, that e.g. allows to call ODI integration scenarios remotely using Web Services calls. ODI Public Web Services uses Apache Axis2 as the web services container.

Installing Axis2 on OC4J 10.1.3. was a real "as easy as 1-2-3" task. Downloaded the WAR Distribution zip file from http://ws.apache.org/axis2/download.cgi, unzipped it on my hard disk and then deployed it using Oracle Application Server control.

After Axis2 WAR deployment, the web services container was ready to rock and to upload the odi-public-ws.aar file required by ODI.

This is just as a reminder for people that wonder how to work with Axis2  and OracleAS.

9 comments:

Hisham said...

Thanks for the post Harri.

I was able to successfully deploy Axis2 to an OC4J instance installed on my windows machine. But when I tried deploying it to an instance on a UNIX box I get "Requested resource not found!" when I try to open the axis2 home. Have you seen this error before?

Thank you.

mshreedhaaran said...

Thanks Harri,

It helped a lot to get started..good helpful post

best regards,
mshreedhaaran

Harri Kaukovuo said...

Thanks. And a reminder for ODI 10.1.3.4.x users is that Axis2 1.2 is supported. You will get problems trying to run Axis2 1.3 or 1.4 but that issues will be resolved in the future patch sets of ODI.

-- Harri

zaloa said...

Hi Harri,

I'm trying to use axis2 1.4 in OC4J 10.1.3.1 and I'm having a lot of problems.
I have already deploy axis2 in OC4J but when I deploy my .aar services in axis2 they don't work (these same services are running alright in tomcat).
First of all I found a mapping problem with the wsdl, and I had to import wsdl4j1.6.2.jar to be able to see the services' wsdl.
My services use hibernate, and when invoking a method I get a toplink exception. I have tried adding hibernate jars but no success.
Can anyone help me with this? I haven't found any documentation regarding this issue...

Thanks in advance,
Zaloa

João Paulo said...

Hi Zoloa,

I have the same problem (i think...)
I tried to publish my ODI webservice through with Axis2 using OC4J and i can´t do this. I have the same on Tomcat and i done this successful.

It´s confused because Axis2/OC4J show a message "Faulty Services"... and the odi-public-ws.aar be into the directory C:\product\10.1.3.1\OracleAS_1\j2ee\home\applications\axis2\axis2\WEB-INF\services\odi-public-ws.aar.

I posted this problem in Oracle Forum and i found a person with the same nick Zaloa... Are you ?

if yes, please see that below:
http://forums.oracle.com/forums/messageview.jspa?messageID=3260808&stqc=true

If you have a solution, please contact me.

Best Regards,

João.

zaloa said...

Hi João,

I never got the solution to my problem. I opened a TAR in metalink and I'm still waiting for a solution. If I ever get this working, I will let you know.

And yes, I am the same one that posted the problem in the otn discussion forums.

Please, let me know if you find how to deploy the .aar files in oc4j and get them working.

Regards,
Zaloa

João Paulo said...

Hi Zoloa, thanks for your reply!

I solved my problem using Axis2 1.2, its better than 1.3 or 1.4 versions if you use OC4J. I saw last Harri´s message about Axis and ODI 10.1.3.4.x version and then substituted it. I done ODI webservice file into Axis2 successfully and had a previous !

But, in my opinion, Tomcat still the best solution because is the more simple, intuitive and free solution than OC4J...I´m still discover benefits between OC4J and Tomcat.

Best Regards,

João.

Cybertron2007 said...

Hi

I'm trying to deploy axis 2 in an axisting ear file.
i have an war file taht contains EJB's and i want to add a wev service attached to the EJB's

please advise on how to deploy?

Luis_eficiente said...

Hi everyone, I have a problem when a try to deploy axis2 into oc4j; my applications .aar don't show and axis_servlet is down...

I need some tutorial or something for deploy axis2 into oc4j server...

Can somebody help to me...